| Main Page | Shadow Forums | Motorcycle Links | Shadowrider's Photo Gallery | Today's Posts | New Posts |



DO NOT POST NUDITY OR PORN OR IT WILL BE DELETED! Thank you.

  
Go Back   Shadowriders > Honda Shadow Discussion Forums > Reviews
User Name
Password
Reply
 
Thread Tools Display Modes

Custom Dynamics LED Cluster F$@ks
Old 01-13-2013, 12:24 AM   #1
PapaSmurfMC
Shadow Master
 
PapaSmurfMC's Avatar
 
PapaSmurfMC is Offline
Join Date: Jul 2012
Location: Philadelphia, PA
Posts: 126
Custom Dynamics LED Cluster F$@ks

One of my winter projects is to overhaul all the signal lighting on my '08 Shadow Spirit, so after a lot of shopping around, I decided to go with LED clusters from Custom Dynamics.



I'm putting Dynamic Clusters in the rear turn signals, which adds running and brake lights to the turn signals, and Dynamic Ringz in the front. I got a bunch of other stuff for other parts of my project but I'll save that for a different post.

Firstly, they don't tell when your order is shipped or send a tracking number so once they acknowledge the order by email, that's pretty much it. After about a week I emailed them to ask for a tracking number and got no answer but the order arrived a couple days later.

First thing I noticed, right through the packaging, was that one of the pair of dynamic clusters was mounted crooked on its trim ring. Under some circumstances, that may not be a problem but I'm also replacing those dorky lollipop lenses with Kuryakyn deep dish bezels with smoke lenses; you can see right though them.




I emailed Custom Dynamics (on a Saturday night) about the problem, attached a picture, and was shocked to get an answer a little later that night. The problem with the cluster was that one of the attached wires was pinched between the cluster and the trim ring and epoxied that way, so it was pushing one side of the cluster up.



I was assured a new cluster would be sent out the next business day and sure enough I got a call that a replacement was being shipped and to expect its arrival in about 3 days. It took twice that. So, not too great on shipping, in general.

Replacement arrived and I found they sent a pair. Since the clusters are supposed to mount from a tiny rectangle of 3M tape from the back of the trim ring to the socket holder of the turn signal, there is a right and a left oriented cluster, different only in the shape of the trim ring and the location of the 3M mounting tape.

I picked out the right side replacement cluster and immediately noticed that the running light and brake light wires, which are supposed to be orange and red, respectively, both looked red. I'm still not sure if they're exactly the same red but they're not nearly as different from eachother as any of the other 3 clusters I had.




So, I wrung out the wiring with a 9V battery to figure out which wire goes where. In the dynamic clusters, a cable terminates in a bulb socket connector for the turn signal functions and the red and orange wires have to be run through the turn signal housing into the brake light housing where you connect them by tapping into the running light wire (brown) and brake light wire (green/yellow) with a pair of PosiTaps, supplied. The PosiTaps work really well but were a tight fit for the gauge of wire used in the brake light.

All this was done, of course, with the fender and pillion frame off of the bike, a major pain in the ass to disassemble, considering I had to remove my saddlebag mounts and sissy bar, first. To test, I had to partially reassemble the fender and pillion frame to plug the cables back in to the bike. Once in, I turned the key and all lights sprang to life, except the right-side replacement cluster looked much brighter than the left-side cluster. I checked all the wiring and all functions (brakes, running lights, turn signals) worked fine; it got even brighter when brakes were applied, so I knew it was hooked up right.

To see if the other replacement cluster they sent was just as bright, I ran some long wires from the battery, hooked them to the replacement left side cluster with clips and compared to the installed left and right clusters. Perfect match for the installed left-side cluster. Great. Disconnect everything, disassemble the fender and pillion frame, pull off the right side turn signal, remove the replacement right-side cluster and replace it with the replacement left-side cluster, reassemble everything, plug everything back in, brightness matches.

I know I said there's a left and a right side cluster and now I have a left-side cluster installed in a right-side turn signal but it's OK because the mounting method supplied by Custom Dynamics is so weak, I'm not going to use it anyway. Since the clusters would just be hanging off of the one tiny square of tape Custom Dynamics supplies, with no support anywhere else in the turn signal housing, there's no way I'm going to trust it mounted that way. How I ended up doing it will be another post; not really relevant to this review.

So, let's recap:
Custom Dynamics has terrible quality control. I got one mechanically defective cluster which they replaced with an electrically defective cluster that also had miscoded wiring. Material quality appears excellent; it's their manufacturing that sucks.
Custom Dynamics has really good technical support. And it's a good thing, because they need it.
Custom Dynamics has average shipping time but poor shipping communication.

Hard to say if I'd buy from them again. They have a lot of problems but they do take care of them. So, if you've got the time and the patience with redoing your work a few times and dealing with tech support and waiting for replacements, I suppose they're OK. Their stuff doesn't seem to be junk, it's just that it's assembled by monkeys and no one seems to notice before they send it to you.

-Ride safe-
PapaSmurfMC
__________________

Last edited by PapaSmurfMC : 01-13-2013 at 01:40 PM.
  Reply With Quote

Old 02-17-2013, 09:07 AM   #2
pilotguy299
Shadow Master
 
pilotguy299's Avatar
 
pilotguy299 is Offline
Join Date: May 2011
Location: Fredneck County Maryland
Posts: 162
WOW. I am sorry to read that you had problems. I've ordered and installed two sets of their LED turn signal boards for my Aero and VTX, and had no problems with either. Well, the boards did seem a bit tight in the turn signal housing, but I guess that is better than too lose.

The LEDs are crazy bright though!

__________________
2008 VTX1300R
2007 Aero750
2006 Rebel250

Last edited by pilotguy299 : 02-17-2013 at 09:11 AM.
  Reply With Quote

Old 04-13-2013, 06:29 AM   #3
CoRider
Shadow Master
 
CoRider's Avatar
 
CoRider is Offline
Join Date: Apr 2013
Location: Aurora, CO
Posts: 289
Might get an LED brake light for the Shadow!
__________________
  Reply With Quote



Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is On
Forum Jump



All times are GMT -4. The time now is 01:07 PM.


vBulletin skin developed by: eXtremepixels
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.